[ANNOUNCE] FIAIF version 1.5.0-1

Bill Babcock email hidden
Sat Jan 4 05:30:32 CET 2003


   Bill Babcock wrote:
   > I've installed the new release.
   > 
   > FYI - I get this:
   > 
   > [snake src]# rpm -Uvh fiaif_1.5.2-0pre1.noarch.rpm --nodeps
   > Preparing...                ########################################### [100%]
   >    1:fiaif                  ########################################### [100%]
   > Configure fiaif and remove the line 'DONT_START=1'
   > from /etc/fiaif/fiaif.conf, then execute
   > '/etc/rc.d/init.d/fiaif start' to start fiaif.
   > /var/tmp/rpm-tmp.14338: line 1: fg: no job control
   > error: %preun(fiaif-1.5.1-2) scriptlet failed, exit status 1
   > /var/tmp/rpm-tmp.14338: line 1: fg: no job control
   > error: %preun(fiaif-1.5.1-3) scriptlet failed, exit status 1
   I do not know why this error occurs. Maybe some RPM experts on the list 
   can explain this.  What distribution are you using?

As I mentioned in an earlier email, RH8.0 - just to reiterate.

As an fyi, when I updated to 1.5.2-0pre3 via 'rpm -Uvh', after the
installation went to 100%, the post install script stuff got hung in a
pause - at least that's what strace showed.

I tried to erase and start again and the erase showed this:

[snake src]# rpm -e fiaif-1.5.2-0pre3
/var/tmp/rpm-tmp.79027: line 1: fg: no job control
error: %preun(fiaif-1.5.2-0pre3) scriptlet failed, exit status 1


and the reinstall got hung in select:
[snake fiaif]# strace -p 16239
select(0, NULL, NULL, NULL, {0, 870000}) = 0 (Timeout)
select(0, NULL, NULL, NULL, {1, 0})     = 0 (Timeout)
select(0, NULL, NULL, NULL, {1, 0})     = 0 (Timeout)
select(0, NULL, NULL, NULL, {1, 0})     = 0 (Timeout)
select(0, NULL, NULL, NULL, {1, 0})     = 0 (Timeout)

[ ad nauseum ]

I'm wondering if this is getting wedged when trying to write out the
/etc/fiaif contents - I noticed a make bug in the tarball (which I
downloaded and tried at one point). I apologize for not finishing
tracking that down and reporting it; it was barfing on the
install-config part, fwiw. I'll try to look at that over the weekend.

   > I also saw this yesterday when cleaning up to start fresh using 'rpm -e'.
   > 
   > FWIW, I still get the error for WATCH_IP.
   > 
   >    Please report back you findings and, if possible, send your fiaif 
   >    configuration files.
   > 
   > Attached find my conf and zone files in a tarball. Note in my
   > zone.int1 the (commented out) 'WATCH_IP=10.1.0.3'.
   > 
   > Let me know if I can help out at all.
   It did. I have located and fixed the bug in 1.5.2-0pre3, which is 
   available from http://fiaif.fugmann.dhs.org/dist/beta

Anyway - this release corrected the issue with WATCH_IP - thanks!

- bill

-- 
                       b i l l   b a b c o c k
               b i l l @ b i l l b a b c o c k . c o m
                w w w . b i l l b a b c o c k . c o m

  Every dark cloud has a silver lining, but lightning kills hundreds
	    of people each year who are trying to find it.
		     -= http://www.despair.com =-






More information about the fiaif mailing list